华为交换机基本配置命令

一、单交换机VLAN划分

命令 命令解释

system 进入系统视图

system-view 进入系统视图

quit 退到系统视图

undo vlan 20 删除vlan 20

sysname 交换机命名

disp vlan 显示vlan

vlan 20 创建vlan(也可进入vlan 20)

port e1/0/1 to e1/0/5 把端口1-5放入VLAN 20 中

 

5700系列

单个端口放入VLAN

l [Huawei]int g0/0/1

l [Huawei]port link-type access (注:接口类型access,hybrid、trunk)

l [Huawei]port default vlan 10

批量端口放入VLAN

l[Huawei]port-group 1

l[Huawei-port-group-1]group-member ethernet G0/0/1 to ethernet G0/0/20

l[Huawei-port-group-1]port hybrid untagged vlan 3

删除group(组) vlan 200内的15端口

l[Huawei]int g0/0/15

l[Huawei-GigabitEthernet0/0/15]undo port hybrid untagged vlan 200

通过group端口限速设置

l[Huawei]Port-group 2

l[Huawei]group-member g0/0/2 to g0/0/23

l[Huawei]qos lr outbound cir 2000 cbs 20000

disp vlan 20 显示vlan里的端口20

int e1/0/24 进入端口24

undo port e1/0/10 表示删除当前VLAN端口10

disp curr 显示当前配置

lreturn 返回

lSave 保存

linfo-center source DS channel 0 log state off trap state off 通过关闭日志信息命令改变DS模块来实现(关闭配置后的确认信息显示)

linfo-center source DS channel 0 log state on trap state on 通过打开日志信息命令改变DS模块来实现(打开配置后的确认信息显示)

二、配置交换机支持TELNE

system 进入系统视图

sysname 交换机命名

int vlan 1 进入VLAN 1

ip address 192.168.3.100 255.255.255.0 配置IP地址

user-int vty 0 4 进入虚拟终端

authentication-mode password (aut password) 设置口令模式

set authentication password simple 222 (set aut pass sim 222) 设置口令

user privilege level 3(use priv lev 3) 配置用户级别

disp current-configuration (disp cur) 查看当前配置

disp ip int 查看交换机VLAN IP配置

删除配置必须退到用户模式

reset saved-configuration(reset saved) 删除配置

Reboot 重启交换机

三、跨交换机VLAN的通讯

在sw1上:

vlan 10 建立VLAN 10

int e1/0/5 进入端口5

port access vlan 10 把端口5加入vlan 10

vlan 20 建立VLAN 20

int e1/0/15 进入端口15

port access vlan 20 把端口15加入VLAN 20

int e1/0/24 进入端口24

port link-type trunk 把24端口设为TRUNK端口

port trunk permit vlan all 同上

在SW2上:

vlan 10 建立VLAN 10

int e1/0/20 进入端口20

port access vlan 10 把端口20放入VLAN 10

int e1/0/24 进入端口24

port link-type trunk 把24端口设为TRUNK端口

port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

disp int e1/0/24 查看端口24是否为TRUNK

undo port trunk permit vlan all 删除该句

四、路由的配置命令

system 进入系统模式

sysname 命名

int e1/0 进入端口

ip address 192.168.3.100 255.255.255.0 设置IP

undo shutdown 打开端口

disp ip int e1/0 查看IP接口情况

disp ip int brief 查看IP接口情况

user-int vty 0 4 进入口令模式

authentication-mode password(auth pass) 进入口令模式

set authentication password simple 222 37 设置口令

user privilege level 3 进入3级特权

save 保存配置

reset saved-configuration 删除配置(用户模式下运行)

undo shutdown 配置远程登陆密码

int e1/4

ip route 192.168.3.0(目标网段) 255.255.255.0 192.168.12.1(下一跳:下一路由器的接口) 静态路由

ip route 0.0.0.0 0.0.0.0 192.168.12.1 默认路由

disp ip rout 显示路由列表

华3C AR-18

E1/0(lan1-lan4)

E2/0(wan0)

E3/0(WAN1)

路由器连接使用直通线。wan0接wan0或wan1接wan1

计算机的网关应设为路由器的接口地址。

五、三层交换机配置VLAN-VLAN通讯

sw1(三层交换机):

system 进入视图

sysname 命名

vlan 10 建立VLAN 10

vlan 20 建立VLAN 20

int e1/0/20 进入端口20

port access vlan 10 把端口20放入VLAN 10

int e1/0/24 进入24端口

port link-type trunk 把24端口设为TRUNK端口

port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

sw2:

vlan 10

int e1/0/5

port access vlan 10

int e1/0/24

port link-type trunk 把24端口设为TRUNK端口

port trunk permit vlan all (port trunk permit vlan 10 只能为vlan 10使用)24端口为所有VLAN使用

sw1(三层交换机):

int vlan 10 创建虚拟接口VLAN 10

ip address 192.168.10.254 255.255.255.0 设置虚拟接口VLAN 10的地址

int vlan 20 创建虚拟接口VLAN 20

ip address 192.168.20.254 255.255.255.0 设置虚拟接口IP VLAN 20的地址

注意:vlan 10里的计算机的网关设为 192.168.10.254

vlan 20里的计算机的网关设为 192.168.20.254

六、动态路由RIP

R1:

int e1/0 进入e1/0端口

ip address 192.168.3.1 255.255.255.0 设置IP

int e2/0 进入e2/0端口

ip adress 192.168.5.1 255.255.255.0 设置IP

rip 设置动态路由

network 192.168.5.0 定义IP

network 192.168.3.0 定义IP

disp ip rout 查看路由接口

R2:

int e1/0 进入e1/0端口

ip address 192.168.4.1 255.255.255.0 设置IP

int e2/0 进入e2/0端口

ip adress 192.168.5.2 255.255.255.0 设置IP

rip 设置动态路由

network 192.168.5.0 定义IP

network 192.168.4.0 定义IP

disp ip rout 查看路由接口

(注意:两台PC机的网关设置PC1 IP:192.168.3.1 PC2 IP:192.168.4.1)

七、IP访问列表

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.168.1.1 255.255.255.0

int e3/0

ip address 192.168.2.1 255.255.255.0

acl number 2001 (2001-2999属于基本的访问列表)

rule 1 deny source 192.168.1.0 0.0.0.255 (拒绝地址192.168.1.0网段的数据通过)

rule 2 permit source 192.168.3.0 0.0.0.255(允许地址192.168.3.0网段的数据通过)

以下是把访问控制列表在接口下应用:

firewall enable

firewall default permit

int e3/0

firewall packet-filter 2001 outbound

disp acl 2001 显示信息

undo acl number 2001 删除2001控制列表

扩展访问控制列表

acl number 3001

rule deny tcp source 192.168.3.0 0.0.0.255 destination 192.168.2.0 0.0.0.255 destination-port eq ftp

必须在r-acl-adv-3001下才能执行

rule permit ip source an destination any (rule permit ip)

int e3/0

firewall enable 开启防火墙

firewall packet-filter 3001 inbound

必须在端口E3/0下才能执行

八、命令的标准访问IP列表(三层交换机):

允许A组机器访问服务器内资料,不允许访问B组机器(服务器没有限制)

sys

vlan 10

name server

vlan 20

name teacher

vlan 30

name student

int e1/0/5

port access vlan 10

int e1/0/10

port access vlan 20

int e1/0/15

port access vlan 30

int vlan 10

ip address 192.168.10.1 255.255.255.0

undo sh

int vlan 20

ip address 192.168.20.1 255.255.255.0

int vlan 30

ip address 192.168.30.1 255.255.255.0

acl number 2001

rule 1 deny source 192.168.30.0 0.0.0.255

rule 2 permit source any

disp acl 2001 查看2001列表

int e1/0/10

port access vlan 20

packet-filter outbound ip-group 2001 rule 1

出口

九、允许A机器访问B机器的FTP但不允许访问WWW,C机器没有任何限制。

vlan 10

vlan 20

vlan 30

int e1/0/5

port access vlan 10

int e1/0/10

port access vlan 20

int e1/0/15

port access vlan 30

int vlan 10

ip address 192.168.10.1 255.255.255.0

undo sh

int vlan 20

ip address 192.168.20.1 255.255.255.0

int vlan 30

ip address 192.168.30.1 255.255.255.0

acl number 3001

rule 1 deny tcp source 192.168.30.0 0.0.0.255 destination 192.168.10.0 0.0.0.255 destination-port eq www

int e1/0/15

packet-filter inbound ip-group 3001 rule 1

进口

十、NAT地址转换(单一静态一对一地址转换)

R1:

sys

sysname R1

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.1.1.1 255.255.255.0

R2:

sys

sysname R2

int e2/0

ip address 192.1.1.2 255.255.255.0

int e1/0

ip address 10.80.1.1 255.255.255.0

回到R1:

nat static 192.168.3.1 192.1.1.1

int e2/0

nat outbound static

ip route 0.0.0.0 0.0.0.0 192.1.1.2

十一、NAT内部整网段地址转换

R1:

sys

sysname R1

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.1.1.1 255.255.255.0

acl number 2008

rule 0 permit source 192.168.3.0 0.0.0.255

rule 1 deny

quit

int e2/0

nat outbound 2008

quit

ip route-static 0.0.0.0 0.0.0.0 192.1.1.2 preference 60

下一个路由接口地址

R2:

sys

sysname R2

int e2/0

ip address 192.1.1.2 255.255.255.0

int e1/0

ip address 10.80.1.1 255.255.255.0

NAT地址池配置:

R1:

sys

sysname R1

int e1/0

ip address 192.168.3.1 255.255.255.0

int e2/0

ip address 192.1.1.1 255.255.255.0

nat address-group 1 192.1.1.1 192.1.1.5 配置地址池

undo address-group 1 删除地址池

acl number 2001 创建访问列表

rule permit source 192.168.1.0 0.0.0.255

允许192.168.1.0/24网段地址转换(ethernet2/0指路由器wan口):

int e2/0

nat outbound 2001 address-group 1 启用协议

ip route 0.0.0.0 0.0.0.0 192.1.1.2 默认路由

R2:

sys

sysname R2

int e1/0

ip address 10.80.1.1 255.255.255.0

int e2/0

ip address 192.1.1.2 255.255.255.0

AR18-22-8配置命令

一、vlan配置

1、vlan划分方案

-------------------------------------------------- ------------------

| 部门 | vlan名 | ip地址 | 端口分配 |

-------------------------------------------------- ------------------

| J室 | vlan10 | 192.168.10.1/24 | ethernet 3/1 |

| K室 | vlan20 | 192.168.20.1/24 | ethernet 3/2 |

| C室 | vlan30 | 192.168.30.1/24 | ethernet 3/3 |

| Server | vlan40 | 192.168.0.1/24 | ethernet 3/{4,5,6} |

-------------------------------------------------- ------------------

2、显示vlan信息的命令

显示指定VLAN 的相关信息。display vlan vid

显示指定VLAN 配置的最大处理报文数目。display vlan max-packet-process vid

显式指定VLAN 的报文统计信息,包括接收和发送的报文数目。display vlan statistics vid vid

显示某个接口的VLAN 配置信息。display vlan interface interface-type interface-num

清除指定VLAN 的报文统计信息。reset vlan statistics vid vid

3、配置物理端口

配置路由器,进入Ethernet 端口视图,指定端口的链路类型,把端口加入到指定vlan中,注意access端口加入的vlan不能是vlan1。

# 配置Ethernet3/1

system-view

 

H3C interface ethernet 3/1 进入端口1

H3C-Ethernet3/1 port link-type access 设置端口类型为access

H3C-Ethernet3/1 port access vlan 10 把该端口加到vlan10中

H3C-Ethernet3/1 quit

# 配置Ethernet3/2

H3C interface ethernet 3/2

H3C-Ethernet3/2 port link-type access

H3C-Ethernet3/2 port access vlan 20

H3C-Ethernet3/2 quit

# 配置Ethernet3/3

H3C interface ethernet 3/3

H3C-Ethernet3/3 port link-type access

H3C-Ethernet3/3 port access vlan 30

H3C-Ethernet3/3 quit

# 配置Ethernet3/4

H3C interface ethernet 3/4

H3C-Ethernet3/4 port link-type access

H3C-Ethernet3/4 port access vlan 40

H3C-Ethernet3/4 quit

# 配置Ethernet3/5

H3C interface ethernet 3/5

H3C-Ethernet3/5 port link-type access

H3C-Ethernet3/5 port access vlan 40

H3C-Ethernet3/5 quit

# 配置Ethernet3/6

H3C interface ethernet 3/6

H3C-Ethernet3/6 port link-type access

H3C-Ethernet3/6 port access vlan 40

H3C-Ethernet3/6 quit

4、配置虚拟端口

VLAN之间要实现互通,需要配置相应的以太网子接口,即VLAN 对应的路由接口,创建并进入相应的子接口视图,为其配置相应的封装协议和关联的VLAN ID,及IP 地址和掩码,ethernet 3/0 是三层虚拟端口。

# 配置Ethernet 3/0.1

H3C interface ethernet 3/0.1 创建并进入子接口

H3C-Ethernet3/0.1 vlan-type dot1q vid 10 设置以太网子接口的封装类型以及相关联的VLAN ID

H3C-Ethernet3/0.1 ip address 192.168.10.1 255.255.255.0

H3C-Ethernet3/0.1 quit

# 配置Ethernet 3/0.2

H3C interface ethernet 3/0.2

H3C-Ethernet3/0.2 vlan-type dot1q vid 20

H3C-Ethernet3/0.2 ip address 192.168.20.1 255.255.255.0

H3C-Ethernet3/0.2 quit

# 配置Ethernet 3/0.3

H3C interface ethernet 3/0.3

H3C-Ethernet3/0.3 vlan-type dot1q vid 30

H3C-Ethernet3/0.3 ip address 192.168.30.1 255.255.255.0

H3C-Ethernet3/0.3 quit

# 配置Ethernet 3/0.4

H3C interface ethernet 3/0.4

H3C-Ethernet3/0.4 vlan-type dot1q vid 40

H3C-Ethernet3/0.4 ip address 192.168.0.1 255.255.255.0

H3C-Ethernet3/0.4 quit

二、DHCP服务器配置

1、检测DHCP服务器

display dhcp server ip-in-use 查看地址池动态地址绑定信息

display dhcp server conflict 查看DHCP地址冲突的统计信息

display dhcp server statistics 查看DHCP服务器的统计信息

display dhcp servertree 查看DHCP地址池结构

2、具体配置

#公共配置(server和relay都适用)

system-view 进入系统视图

 

H3C dhcp enable 使能DHCP服务

H3C dhcp server detect 使能伪DHCP服务器检测功能

#全局地址池配置

H3C dhcp select global interface ethernet 3/0.1 to ethernet 3/0.4 配置接口工作在DHCP Server模式,从全局地址池分配地址

H3C dhcp server ip-pool vlan10 创建全局地址池vlan10(最多支持128个全局地址池/路由器)

H3C-ip-pool network 192.168.10.0 mask 255.255.255.0 配置动态分配的IP地址范围(只可配置1个/地址池)

H3C-ip-pool expired day 7 hour 23 minute 59 配置租约

H3C-ip-pool domain-name pearl.cn 配置域名

H3C-ip-pool dns-list ip-address 192.168.0.6 202.106.0.20 202.106.196.115 配置DNS(最多8个/地址池)

H3C-ip-pool gateway-list ip-address 192.168.10.1 配置默认网关(最多8个/地址池)

H3C dhcp server forbidden-ip 192.168.10.1 192.168.10.10 配置保留IP地址范围(可配置多个/地址池)

H3C dhcp server relay information enable 使能DHCP Server支持option 82

#接口地址池配置

H3C dhcp select interface interface ethernet 3/0.1 to ethernet 3/0.4 (指虚拟接口还是指物理接口???)

配置多个接口工作在DHCP Server模式,从接口地址池分配地址,同时自动创建“接口地址池”

H3C dhcp server expired day 7 hour 23 minute 59 interface ethernet 3/0.1 to ethernet 3/0.4

H3C dhcp server domain-name pearl.cn interface ethernet 3/0.1 to ethernet 3/0.4

H3C dhcp server dns-list ip-address 192.168.0.6 202.106.0.20 202.106.196.115 interface ethernet 3/0.1 to ethernet 3/0.4

H3C interface ethernet 3/0.1

H3C-interface gateway-list ip-address 192.168.10.1

H3C dhcp server forbidden-ip 192.168.10.1 192.168.10.10 (是否接口模式下配??)

H3C dhcp server relay information enable

三、NAT配置

#配置地址池和访问控制列表:

H3C nat address-group 1 222.128.28.172 222.128.28.174

H3C acl number 2001

H3C-acl-basic-2001rule permit source 192.168.0.0 0.0.0.255

#允许192.168.0.0/24网段地址转换(ethernet3/0指路由器wan口):

H3C interface ethernet3/0

H3C-ethernet3/0 nat outbound 2001 address-group 1

#设置内部FTP服务器:

H3C-ethernet3/0 nat server protocol tcp global 222.128.28.171 inside 192.168.0.8 ftp

#设置内部www服务器1:

H3C-ethernet3/0 nat server protocol tcp global 222.128.28.171 inside 192.168.0.9 www

#设置内部www服务器2:

H3C-ethernet3/0 nat server protocol tcp global 222.128.28.171 8080 inside 192.168.0.10 www

1、配置文件相关命令

[Quidway]display current-configuration 显示当前生效的配置

[Quidway]display saved-configuration 显示flash中配置文件,即下次上电启动时所用

的配置文件

reset saved-configuration 檫除旧的配置文件

reboot 交换机重启

display version 显示系统版本信息

2、基本配置

[Quidway]super password 修改特权用户密码

[Quidway]sysname 交换机命名

[Quidway]interface ethernet 1/0/1 进入接口视图

[Quidway]interface vlan 1 进入接口视图

[Quidway-Vlan-interfacex]ip address 10.1.1.11 255.255.0.0 配置VLAN的IP地址

[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.1.1.1 静态路由=网关

3、telnet配置

[Quidway]user-interface vty 0 4 进入虚拟终端

[S3026-ui-vty0-4]authentication-mode password 设置口令模式

[S3026-ui-vty0-4]set authentication-mode password simple xmws123 设置口令

[S3026-ui-vty0-4]user privilege level 3 用户级别

4、端口配置

[Quidway-Ethernet1/0/1]duplex {half|full|auto} 配置端口工作状态

[Quidway-Ethernet1/0/1]speed {10|100|auto} 配置端口工作速率

[Quidway-Ethernet1/0/1]flow-control 配置端口流控

[Quidway-Ethernet1/0/1]mdi {across|auto|normal} 配置端口平接扭接

[Quidway-Ethernet1/0/1]port link-type {trunk|access|hybrid} 设置端口工作模式

[Quidway-Ethernet1/0/1]undo shutdown 激活端口

[Quidway-Ethernet1/0/2]quit 退出系统视图

5、链路聚合配置

[DeviceA] link-aggregation group 1 mode manual 创建手工聚合组1

[Qw_A] interface ethernet 1/0/1 将以太网端口Ethernet1/0/1加入聚合组1

[Qw_A-Ethernet1/0/1] port link-aggregation group 1

[Qw_A-Ethernet1/0/1] interface ethernet 1/0/2 将以太网端口Ethernet1/0/1加入聚合组1

[Qw_A-Ethernet1/0/2] port link-aggregation group 1

[Qw_A] link-aggregation group 1 service-type tunnel # 在手工聚合组的基础上创建

tunnel业务环回组。

[Qw_A] interface ethernet 1/0/1 将以太网端口Ethernet1/0/1加入业务环回组。

[Qw_A-Ethernet1/0/1] undo stp

[Qw_A-Ethernet1/0/1] port link-aggregation group 1

6、端口镜像

[Quidway]monitor-port  指定镜像端口

[Quidway]port mirror    指定被镜像端口

[Quidway]port mirror int_list observing-port int_type int_num 指定镜像和被镜像

7、VLAN配置

[Quidway]vlan 4        创建VLAN

[Quidway-vlan4]port ethernet 1/0/1 to ethernet 1/0/4     在VLAN中增加端口

① 配置基于access的VLAN

[Quidway-Ethernet1/0/2]port access vlan 4       当前端口加入到VLAN

注意:缺省情况下,端口的链路类型为Access类型,所有Access端口均属于且只属于VLAN1

② 配置基于trunk的VLAN

[Quidway-Ethernet 1/0/24]port link-type trunk 设置当前端口为trunk

[Quidway-Ethernet 1/0/24]port trunk permit vlan {ID|All}   设trunk允许的VLAN

注意:所有端口缺省情况下都是允许VLAN1的报文通过的

[Quidway-Ethernet1/0/2]port trunk pvid vlan 34      设置trunk端口的PVID

③ 配置基于Hybrid端口的VLAN

[Quidway-Ethernet1/0/2]port link-type hybrid 配置端口的链路类型为Hybrid类型

[Quidway-Ethernet1/0/2]port hybrid vlan vlan-id-list { tagged | untagged } 允许指定的VLAN

通过当前Hybrid端口

注意:缺省情况下,所有Hybrid端口只允许VLAN1通过

[Quidway-Ethernet1/0/2]port hybrid pvid vlan vlan-id 设置Hybrid端口的缺省VLAN

注意:缺省情况下,Hybrid端口的缺省VLAN为VLAN1

④ VLAN描述

[Quidway]description string      指定VLAN描述字符

[Quidway]undo description     删除VLAN描述字符

[Quidway]display vlan [vlan_id] 查看VLAN设置

⑤ 私有VLAN配置

[Qw_A-vlanx]isolate-user-vlan enable       设置主vlan

[Qw_A]Isolate-user-vlan secondary       设置主vlan包括的子vlan

[Quidway-Ethernet1/0/2]port hybrid pvid vlan    设置vlan的pvid

[Quidway-Ethernet1/0/2]port hybrid pvid      删除vlan的pvid

[Quidway-Ethernet1/0/2]port hybrid vlan vlan_id_list untagged  设置无标识的vlan

如果包的vlan id与PVId一致,则去掉vlan信息. 默认PVID=1。

所以设置PVID为所属vlan id, 设置可以互通的vlan为untagged.

8、STP配置

[Quidway]stp {enable|disable} 设置生成树,默认关闭

[Quidway]stp mode rstp 设置生成树模式为rstp

[Quidway]stp priority 8192     设置交换机的优先级

[Quidway]stp root {primary|secondary}    设置为根或根的备份

[Quidway-Ethernet0/1]stp cost 200     设置交换机端口的花费

MSTP配置:

# 配置MST域名为info,MSTP修订级别为1,VLAN映射关系为VLAN2~VLAN10映射到生成树实例1上,VLAN20~VLAN30映射生成树实例2上。

system-view

[Sysname] stp region-configuration

[Sysname-mst-region] region-name info

[Sysname-mst-region] instance 1 vlan 2 to 10

[Sysname-mst-region] instance 2 vlan 20 to 30

[Sysname-mst-region] revision-level 1

[Sysname-mst-region] active region-configuration

9、MAC地址表的操作

① 在系统视图下添加MAC地址表项

[Quidway]mac-address { static | dynamic | blackhole } mac-address interface interface-type interface-number vlan vlan-id ;添加MAC地址表项

在添加MAC地址表项时,命令中interface参数指定的端口必须属于vlan参数指定的VLAN,否则将添加失败。

如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。

② 在以太网端口视图下添加MAC地址表项

[Quidway-Ethernet1/0/2]mac-address { static | dynamic | blackhole } mac-address vlan vlan-id

在添加MAC地址表项时,当前的端口必须属于命令中vlan参数指定的VLAN,否则将添加失败;

如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。

[Quidway]mac-address timer { aging age | no-aging } 设置MAC地址表项的老化时间

注意:缺省情况下,MAC地址表项的老化时间为300秒,使用参数no-aging时表示不对MAC地址表项进行老化。

③ MAC地址老化时间的配置对所有端口都生效,但地址老化功能只对动态的(学习到的或者用户配置可老化的)MAC地址表项起作用。

[Quidway-Ethernet1/0/2]mac-address max-mac-count count 设置端口最多可以学习到的MAC地址数量;

注意:缺省情况下,没有配置对端口学习MAC地址数量的限制。反之,如果端口启动了MAC地址认证和端口安全功能,则不能配置该端口的最大MAC地址学习个数。

[Quidway-Ethernet1/0/2]port-mac start-mac-address 配置以太网端口MAC地址的起始值

在缺省情况下,E126/E126A交换机的以太网端口是没有配置MAC地址的,因此当交换机在发送二层协议报文(例如STP)时,由于无法取用发送端口的MAC地址,将使用该协议预置的MAC地址作为源地址填充到报文中进行发送。在实际组网中,由于多台设备都使用相同的源MAC地址发送二层协议报文,会造成在某台设备的不同端口学习到相同MAC地址的情况,可能会对MAC地址表的维护产生影响。

[Quidway]display mac-address 显示地址表信息

[Quidway]display mac-address aging-time 显示地址表动态表项的老化时间

[Quidway]display port-mac 显示用户配置的以太网端口MAC地址的起始值

10、GVRP配置

[Qw_A] gvrp 开启全局GVRP

[Qw_A-Ethernet1/0/1] gvrp 在以太网端口Ethernet1/0/1上开启GVRP

[Qw_A-Ethernet1/0/1] gvrp registration { fixed | forbidden | normal }

配置GVRP端口注册模式 ,缺省为normal。

[Qw_A] display garp statistics [ interface interface-list ] 显示GARP统计信息

[Qw_A] display garp timer [ interface interface-list ] 显示GARP定时器的值

[Qw_A] display gvrp statistics [ interface interface-list ] 显示GVRP统计信息

[Qw_A] display gvrp status 显示GVRP的全局状态信息

[Qw_A] display gvrp statusreset garp statistics [ interface interface-list ] 清除GARP统计

11、DLDP配置

[Qw_A] interface gigabitethernet 1/1/1

[Qw_A-GigabitEthernet1/1/1] duplex full 配置端口工作在强制全双工模式

[Qw_A-GigabitEthernet1/1/1] speed 1000 速率为1000Mbits/s

[Qw_A] dldp enable 全局开启DLDP。

[Qw_A] dldp interval 15 设置发送DLDP报文的时间间隔为15秒。

[Qw_A] dldp work-mode { enhance | normal }

配置DLDP协议的工作模式为加强模式。 缺省为normal。

[Qw_A] dldp unidirectional-shutdown { auto | manual }

配置DLDP单向链路操作模式为自动模式。 缺省为auto

Qw_A] display dldp 1 查看DLDP状态。

① 当光纤交叉连接时,可能有两个或三个端口处于Disable状态,剩余端口处于Inactive状态。

② 当光纤一端连接正确,一端未连接时:

如果DLDP的工作模式为normal,则有收光的一端处于Advertisement状态,没有收光的一端处于Inactive状态。

如果DLDP的工作模式为enhance,则有收光的一端处于Disable状态,没有收光的一端处于Inactive状态。

③ dldp reset命令在全局下可以重置所有端口的DLDP状态,在接口下可以充值该端口的DLDP状态

12、端口隔离配置

① 通过端口隔离特性,用户可以将需要进行控制的端口加入到一个隔离组中,实现隔离组中的端口之间二层、三层数据的隔离,既增强了网络的安全性,也为用户提供了灵活的组网方案。

[Sysname] interface ethernet1/0/2 将以太网端口Ethernet1/0/2加入隔离组。

[Sysname-Ethernet1/0/2] port isolate

[Sysname] display isolate port 显示隔离组中的端口信息

② 配置隔离组后,只有隔离组内各个端口之间的报文不能互通,隔离组内端口与隔离组外端口以及隔离组外端口之间的通信不会受到影响。

③ 端口隔离特性与以太网端口所属的VLAN无关。

④ 当汇聚组中的某个端口加入或离开隔离组后,本设备中同一汇聚组内的其它端口,均会自动加入或离开该隔离组。

⑤ 对于既处于某个聚合组又处于某个隔离组的一组端口,其中的一个端口离开聚合组时不会影响其他端口,即其他端口仍将处于原聚合组和原隔离组中。

⑥ 如果某个聚合组中的端口同时属于某个隔离组,当在系统视图下直接删除该聚合组后,该聚合组中的端口仍将处于该隔离组中。

⑦ 当隔离组中的某个端口加入聚合组时,该聚合组中的所有端口,会自动加入隔离组中。

13、端口安全配置

[Switch] port-security enable 启动端口安全功能

[Switch] interface Ethernet 1/0/1 进入以太网Ethernet1/0/1端口视图

[Switch-Ethernet1/0/1] port-security max-mac-count 80

设置端口允许接入的最大MAC地址数为80

[Switch-Ethernet1/0/1] port-security port-mode autolearn 配置端口的安全模式为autolearn

[Switch-Ethernet1/0/1] mac-address security 0001-0002-0003 vlan 1

将Host 的MAC地址0001-0002-0003作为Security MAC添加到VLAN 1中

[Switch-Ethernet1/0/1] port-security intrusion-mode disableport-temporarily

设置Intrusion Protection特性被触发后,暂时关闭该端口

[Switch]port-security timer disableport 30 关闭时间为30秒。

14、端口绑定配置

通过端口绑定特性,网络管理员可以将用户的MAC地址和IP地址绑定到指定的端口上。进行绑定操作后,交换机只对从该端口收到的指定MAC地址和IP地址的用户发出的报文进行转发,提高了系统的安全性,增强了对网络安全的监控。

[Qw_A-Ethernet1/0/1] am user-bind mac-addr 0001-0002-0003 ip-addr 10.12.1.1

将Host 1的MAC地址和IP地址绑定到Ethernet1/0/1端口。

有的交换机上绑定的配置不一样

[Qw_A] interface ethernet 1/0/2

[Qw_A-Ethernet1/0/2] user-bind ip-address 192.168.0.3 mac-address 0001-0203-0405

端口过滤配置

[Qw_A] interface ethernet1/0/1 配置端口Ethernet1/0/1的端口过滤功能。

[Qw_A-Ethernet1/0/1] ip check source ip-address mac-address

[Qw_A] dhcp-snooping 开启DHCP Snooping功能。

[Qw_A] interface ethernet1/0/2

设置与DHCP服务器相连的端口Ethernet1/0/2为信任端口。

[Qw_A-Ethernet1/0/2] dhcp-snooping trust

在端口Ethernet1/0/1上启用IP过滤功能,防止客户端使用伪造的不同源IP地址对服务器进行攻击

15、BFD配置

Qw_A、Qw_B、Qw_C相互可达,在Qw_A上配置静态路由可以到达Qw_C,并使能BFD检测功能。

① 在Qw_A上配置静态路由,并使能BFD检测功能,通过BFD echo报文方式实现BFD功能。

Qw_A> system-view

[Qw_A] bfd echo-source-ip 123.1.1.1

[Qw_A] interface vlan-interface 10

[Qw_A-vlan-interface10] bfd min-echo-receive-interval 300

[Qw_A-vlan-interface10] bfd detect-multiplier 7

[Qw_A-vlan-interface10] quit

[Qw_A] ip route-static 120.1.1.1 24 10.1.1.100 bfd echo-packet

② 在Qw_A上打开BFD功能调试信息开关。

Qw_A> debugging bfd event

Qw_A> debugging bfd scm

Qw_A> terminal debugging

③ 在Qw_A上可以打开BFD功能调试信息开关,断开Hub和Qw_B之间的链路,验证配置结果。验证结果显示,

④ Qw_A能够快速感知Qw_A与Qw_B之间链路的变化。

16、QinQ配置

Provider A、Provider B之间通过Trunk端口连接,Provider A属于运营商网络的VLAN1000,Provider B属于运营商网络的VLAN2000。

Provider A和Provider B之间,运营商采用其他厂商的设备,TPID值为0x8200。

希望配置完成后达到下列要求:

Customer A的VLAN10的报文可以和Customer B的VLAN10的报文经过运营商网络的VLAN1000转发后互通;Customer A的VLAN20的报文可以

和Customer C的VLAN20的报文经过运营商网络的VLAN2000转发后互通。

[ProviderA] interface ethernet 1/0/1 # 配置端口为Hybrid端口,且允许VLAN10,VLAN20,VLAN1000和VLAN2000的报文通过,并且在发送时去掉外层Tag。

[ProviderA-Ethernet1/0/1] port link-type hybrid

[ProviderA-Ethernet1/0/1] port hybrid vlan 10 20 1000 2000 untagged

[ProviderA-Ethernet1/0/1] qinq vid 1000

将来自VLAN10的报文封装VLAN ID为1000的外层Tag。

[ProviderA-Ethernet1/0/1-vid-1000] raw-vlan-id inbound 10

[ProviderA-Ethernet1/0/1-vid-1000] quit

[ProviderA-Ethernet1/0/1] qinq vid 2000

将来自VLAN20的报文封装VLAN ID为2000的外层Tag。

[ProviderA-Ethernet1/0/1-vid-2000] raw-vlan-id inbound 20

[ProviderA] interface ethernet 1/0/2 配置端口的缺省VLAN为VLAN1000。

[ProviderA-Ethernet1/0/2] port access vlan 1000

[ProviderA-Ethernet1/0/2] qinq enable

配置端口的基本QinQ功能,将来自VLAN10的报文封装VLAN ID为1000的外层Tag。

[ProviderA] interface ethernet 1/0/3

配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。

[ProviderA-Ethernet1/0/3] port link-type trunk

[ProviderA-Ethernet1/0/3] port trunk permit vlan 1000 2000

[ProviderA-Ethernet1/0/3] qinq ethernet-type 8200

为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200。

[ProviderB] interface ethernet 1/0/1

配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。

[ProviderB-Ethernet1/0/1] port link-type trunk

[ProviderB-Ethernet1/0/1] port trunk permit vlan 1000 2000

[ProviderB-Ethernet1/0/1] qinq ethernet-type 8200

为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200。

[ProviderB-Ethernet1/0/1] quit

[ProviderB] interface ethernet 1/0/2 # 配置端口的缺省VLAN为VLAN2000。

[ProviderB-Ethernet1/0/2] port access vlan 2000

[ProviderB-Ethernet1/0/2] qinq enable

配置端口的基本QinQ功能,将来自VLAN20的报文封装VLAN ID为2000的外层Tag。

点赞