华为交换机配置命令总结

1.配置telnet设置mode为password提示错误,以及远程设置权限等级

命令:user-intercace  vty  0 4
		auth	mode password  报错
		解决: 
		protect inbord  all

完整配置
	>telnet server en
	]user-interface vty 0
	]protocol inbound all
	]authentication-mode passwor
	]user privilege level 
	]set authentication password cipher   密码

2.telnet 配置完成无法远程连接

缺少huawei]telnet server enable

3.华为9600光口连接网络无法联通

	HW]interface GigabitEthernet1/0/3
	[G1/0/3]dis  this
				 port link-type access
				 port default vlan 5
				 combo copper        显示为电口
[G1/0/3]combo ?
	 copper  copper       电口
	 fiber   fiber	 			光口
修改接口类型即可

4.s2700下联s5700通过多模连接,交换机指示灯不亮

display transceiver intface g/0/25 verbose #查看光模块信息
查看提示信息协商协议
huawei]undo undo negotiation auto
指示灯亮起

5.5700poe交换机配置下联设备需要关闭poe供电

huawei>undo poe enable

6.一台2700s设备配置命令都正确但是无法ping通上联的交换机

>dis cpu 查看cpu
>dis memory-usage   查看内存使用情况
显示内存占用为65% ,reboot交换机后,再次ping显示联通

7.trunk 改access

]undo port trunk all-pa vlan all
]port trunk all pass vlan 1    
]port link-t access
]port default vlan vlanid

8.华为交换机忘记密码
https://blog.csdn.net/IO_print/article/details/103138069t

9 问题描述:s5700LI设备配置vlanif时出现警告

[S5710LI]interface Vlanif 8
	Error: Can not create this interface because the interface number of this type has reached its maximum. 
	
处理过程:
	huawei]dis version 产看版本信息
	在v200r001到v200r003版本,由于S5700LI设备是S5700谢列交换机中的二层交换机,规格上只支持一个vlanif接口。
	当配置	多个vlanif接口时会出现错误(缺省存在vlanif 1)。
解决方案
	1.若S5700LI只需要使用到一个vlanif接口,而不希望使用缺省的vlanif接口,需要先
		huawei]undo interface vlanif 1,再创建新的vlanif接口;
	2,若S5700LI设备需要用到多个vlanif接口,需要升级到v200r005及以后版本(目前版本最大支持8个vlanif接口)

10.配置aaa认证后使用用户名密码无法登陆(telnet 和 console 无法登陆)

dis cu 发现 local-user 用户名 service-type http 
解决: undo local-user 用户名 service-type 

11.配置super密码

交换件配置
	[S5710LI] super password level 权限等级 cipher 密码
	用户使用提升权限 super 权限等级

12.通过端口查看IP

dis arp | include g0/0/1

13.DHCP排除已经分配出去的地址报错


error:only idle or expird IP address can be disabled
解决::查看地址池使用情况 
>dis ip pool name pool_name used
>回收IP地址
>reset ip pool pool_name 192.168.0.12
然后在dhcp中排除地址

华为交换机常见配置

1、配置文件相关命令

[Quidway]display current-configuration              #显示当前生效的配置
[Quidway]display saved-configuration              #  显示flash中配置文件,即下次上电启动时所用的配置文件
reset saved-configuration                       #     檫除旧的配置文件
reboot               #交换机重启
display version       显示系统版本信息

2、基本配置

[Quidway]super password               #修改特权用户密码
[Quidway]sysname                      #交换机命名
[Quidway]interface ethernet 1/0/1               #进入接口视图
[Quidway]interface vlan 1               #进入接口视图
[Quidway-Vlan-interfacex]ip address 10.1.1.11 255.255.0.0      # 配置VLAN的IP地址
[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.1.1.1              #静态路由=网关

3、telnet配置

[Quidway]user-interface vty 0 4               #进入虚拟终端
[S3026-ui-vty0-4]authentication-mode password               #设置口令模式
[S3026-ui-vty0-4]set authentication-mode password simple xmws123              # 设置口令
[S3026-ui-vty0-4]user privilege level 3                     # 用户级别

4、端口配置

[Quidway-Ethernet1/0/1]duplex {half|full|auto}                #配置端口工作状态
[Quidway-Ethernet1/0/1]speed {10|100|auto}                   #配置端口工作速率
[Quidway-Ethernet1/0/1]flow-control               #配置端口流控
[Quidway-Ethernet1/0/1]mdi {across|auto|normal}             #配置端口平接扭接
[Quidway-Ethernet1/0/1]port link-type {trunk|access|hybrid}   #设置端口工作模式
[Quidway-Ethernet1/0/1]undo shutdown               #激活端口
[Quidway-Ethernet1/0/2]quit               #退出系统视图

5、链路聚合配置

[DeviceA] link-aggregation group 1 mode manual              # 创建手工聚合组1
[Qw_A] interface ethernet 1/0/1               #将以太网端口Ethernet1/0/1加入聚合组1
[Qw_A-Ethernet1/0/1] port link-aggregation group 1
[Qw_A-Ethernet1/0/1] interface ethernet 1/0/2               #将以太网端口Ethernet1/0/1加入聚合组1
[Qw_A-Ethernet1/0/2] port link-aggregation group 1
[Qw_A] link-aggregation group 1 service-type tunnel         # 在手工聚合组的基础上创建
tunnel业务环回组。
[Qw_A] interface ethernet 1/0/1               #将以太网端口Ethernet1/0/1加入业务环回组。
[Qw_A-Ethernet1/0/1] undo stp
[Qw_A-Ethernet1/0/1] port link-aggregation group 1

6、端口镜像

[Quidway]monitor-port  指定镜像端口
[Quidway]port mirror    指定被镜像端口
[Quidway]port mirror int_list observing-port int_type int_num 指定镜像和被镜像

7、VLAN配置

[Quidway]vlan 4                    创建VLAN
[Quidway-vlan4]port ethernet 1/0/1 to ethernet 1/0/4     在VLAN中增加端口

① 配置基于access的VLAN

[Quidway-Ethernet1/0/2]port access vlan 4       当前端口加入到VLAN

注意:缺省情况下,端口的链路类型为Access类型,所有Access端口均属于且只属于VLAN1
② 配置基于trunk的VLAN

[Quidway-Ethernet 1/0/24]port link-type trunk               #设置当前端口为trunk
[Quidway-Ethernet 1/0/24]port trunk permit vlan {ID|All}                # 设trunk允许的VLAN

注意:所有端口缺省情况下都是允许VLAN1的报文通过的

[Quidway-Ethernet1/0/2]port trunk pvid vlan 34                  #  设置trunk端口的PVID

③ 配置基于Hybrid端口的VLAN

[Quidway-Ethernet1/0/2]port link-type hybrid              # 配置端口的链路类型为Hybrid类型
[Quidway-Ethernet1/0/2]port hybrid vlan vlan-id-list { tagged | untagged }               #允许指定的VLAN

通过当前Hybrid端口
注意:缺省情况下,所有Hybrid端口只允许VLAN1通过

[Quidway-Ethernet1/0/2]port hybrid pvid vlan vlan-id               #设置Hybrid端口的缺省VLAN

注意:缺省情况下,Hybrid端口的缺省VLAN为VLAN1
④ VLAN描述

[Quidway]description string                   # 指定VLAN描述字符
[Quidway]undo description                  # 删除VLAN描述字符
[Quidway]display vlan [vlan_id]               #查看VLAN设置

⑤ 私有VLAN配置

[Qw_A-vlanx]isolate-user-vlan enable                      # 设置主vlan
[Qw_A]Isolate-user-vlan secondary                      #  设置主vlan包括的子vlan
[Quidway-Ethernet1/0/2]port hybrid pvid vlan                 # 设置vlan的pvid
[Quidway-Ethernet1/0/2]port hybrid pvid                     # 删除vlan的pvid
[Quidway-Ethernet1/0/2]port hybrid vlan vlan_id_list untagged              #  设置无标识的vlan

如果包的vlan id与PVId一致,则去掉vlan信息. 默认PVID=1。
所以设置PVID为所属vlan id, 设置可以互通的vlan为untagged.

8、STP配置

[Quidway]stp {enable|disable}              # 设置生成树,默认关闭
[Quidway]stp mode rstp               #设置生成树模式为rstp
[Quidway]stp priority 8192                  # 设置交换机的优先级
[Quidway]stp root {primary|secondary}       设置为根或根的备份
[Quidway-Ethernet0/1]stp cost 200          设置交换机端口的花费

MSTP配置:
#配置MST域名为info,MSTP修订级别为1,VLAN映射关系为VLAN2~VLAN10映射到生成树实例1上,VLAN20~VLAN30映射生成树实例2上。

system-view
[Sysname] stp region-configuration
[Sysname-mst-region] region-name info
[Sysname-mst-region] instance 1 vlan 2 to 10
[Sysname-mst-region] instance 2 vlan 20 to 30
[Sysname-mst-region] revision-level 1
[Sysname-mst-region] active region-configuration

9、MAC地址表的操作

① 在系统视图下添加MAC地址表项

[Quidway]mac-address { static | dynamic | blackhole } mac-address interface interface-type interface-number vlan vlan-id ;添加MAC地址表项

在添加MAC地址表项时,命令中interface参数指定的端口必须属于vlan参数指定的VLAN,否则将添加失败。
如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。
② 在以太网端口视图下添加MAC地址表项

[Quidway-Ethernet1/0/2]mac-address { static | dynamic | blackhole } mac-address vlan vlan-id

在添加MAC地址表项时,当前的端口必须属于命令中vlan参数指定的VLAN,否则将添加失败;
如果vlan参数指定的VLAN是动态VLAN,在添加静态MAC地址之后,会自动变为静态VLAN。
[Quidway]mac-address timer { aging age | no-aging } 设置MAC地址表项的老化时间
注意:缺省情况下,MAC地址表项的老化时间为300秒,使用参数no-aging时表示不对MAC地址表项进行老化。
③ MAC地址老化时间的配置对所有端口都生效,但地址老化功能只对动态的(学习到的或者用户配置可老化的)MAC地址表项起作用。

[Quidway-Ethernet1/0/2]mac-address max-mac-count count              # 设置端口最多可以学习到的MAC地址数量;

注意:缺省情况下,没有配置对端口学习MAC地址数量的限制。反之,如果端口启动了MAC地址认证和端口安全功能,则不能配置该端口的最大MAC地址学习个数。

[Quidway-Ethernet1/0/2]port-mac start-mac-address               #配置以太网端口MAC地址的起始值

在缺省情况下,E126/E126A交换机的以太网端口是没有配置MAC地址的,因此当交换机在发送二层协议报文(例如STP)时,由于无法取用发送端口的MAC地址,将使用该协议预置的MAC地址作为源地址填充到报文中进行发送。在实际组网中,由于多台设备都使用相同的源MAC地址发送二层协议报文,会造成在某台设备的不同端口学习到相同MAC地址的情况,可能会对MAC地址表的维护产生影响。

[Quidway]display mac-address              # 显示地址表信息
[Quidway]display mac-address aging-time               #显示地址表动态表项的老化时间
[Quidway]display port-mac                   # 显示用户配置的以太网端口MAC地址的起始值

10、GVRP配置

[Qw_A] gvrp 开启全局GVRP

[Qw_A-Ethernet1/0/1] gvrp 在以太网端口Ethernet1/0/1上开启GVRP
[Qw_A-Ethernet1/0/1] gvrp registration { fixed | forbidden | normal }

配置GVRP端口注册模式 ,缺省为normal。

[Qw_A] display garp statistics [ interface interface-list ] 显示GARP统计信息
[Qw_A] display garp timer [ interface interface-list ] 显示GARP定时器的值
[Qw_A] display gvrp statistics [ interface interface-list ] 显示GVRP统计信息
[Qw_A] display gvrp status 显示GVRP的全局状态信息
[Qw_A] display gvrp statusreset garp statistics [ interface interface-list ] 清除GARP统计

11、DLDP配置

[Qw_A] interface gigabitethernet 1/1/1
[Qw_A-GigabitEthernet1/1/1] duplex full 配置端口工作在强制全双工模式
[Qw_A-GigabitEthernet1/1/1] speed 1000 速率为1000Mbits/s
[Qw_A] dldp enable 全局开启DLDP。
[Qw_A] dldp interval 15 设置发送DLDP报文的时间间隔为15秒。
[Qw_A] dldp work-mode { enhance | normal }

配置DLDP协议的工作模式为加强模式。 缺省为normal。

[Qw_A] dldp unidirectional-shutdown { auto | manual }

配置DLDP单向链路操作模式为自动模式。 缺省为auto
Qw_A] display dldp 1 查看DLDP状态。
① 当光纤交叉连接时,可能有两个或三个端口处于Disable状态,剩余端口处于Inactive状态。
② 当光纤一端连接正确,一端未连接时:
如果DLDP的工作模式为normal,则有收光的一端处于Advertisement状态,没有收光的一端处于Inactive状态。
如果DLDP的工作模式为enhance,则有收光的一端处于Disable状态,没有收光的一端处于Inactive状态。
③ dldp reset命令在全局下可以重置所有端口的DLDP状态,在接口下可以充值该端口的DLDP状态

12、端口隔离配置

① 通过端口隔离特性,用户可以将需要进行控制的端口加入到一个隔离组中,实现隔离组中的端口之间二层、三层数据的隔离,既增强了网络的安全性,也为用户提供了灵活的组网方案。

[Sysname] interface ethernet1/0/2 将以太网端口Ethernet1/0/2加入隔离组。
[Sysname-Ethernet1/0/2] port isolate
[Sysname] display isolate port 显示隔离组中的端口信息

② 配置隔离组后,只有隔离组内各个端口之间的报文不能互通,隔离组内端口与隔离组外端口以及隔离组外端口之间的通信不会受到影响。
③ 端口隔离特性与以太网端口所属的VLAN无关。
④ 当汇聚组中的某个端口加入或离开隔离组后,本设备中同一汇聚组内的其它端口,均会自动加入或离开该隔离组。
⑤ 对于既处于某个聚合组又处于某个隔离组的一组端口,其中的一个端口离开聚合组时不会影响其他端口,即其他端口仍将处于原聚合组和原隔离组中。
⑥ 如果某个聚合组中的端口同时属于某个隔离组,当在系统视图下直接删除该聚合组后,该聚合组中的端口仍将处于该隔离组中。
⑦ 当隔离组中的某个端口加入聚合组时,该聚合组中的所有端口,会自动加入隔离组中。

13、端口安全配置

[Switch] port-security enable 启动端口安全功能
[Switch] interface Ethernet 1/0/1 进入以太网Ethernet1/0/1端口视图
[Switch-Ethernet1/0/1] port-security max-mac-count 80
设置端口允许接入的最大MAC地址数为80
[Switch-Ethernet1/0/1] port-security port-mode autolearn 配置端口的安全模式为autolearn
[Switch-Ethernet1/0/1] mac-address security 0001-0002-0003 vlan 1
将Host 的MAC地址0001-0002-0003作为Security MAC添加到VLAN 1[Switch-Ethernet1/0/1] port-security intrusion-mode disableport-temporarily
设置Intrusion Protection特性被触发后,暂时关闭该端口
[Switch]port-security timer disableport 30 关闭时间为30.

14、端口绑定配置

通过端口绑定特性,网络管理员可以将用户的MAC地址和IP地址绑定到指定的端口上。进行绑定操作后,交换机只对从该端口收到的指定MAC地址和IP地址的用户发出的报文进行转发,提高了系统的安全性,增强了对网络安全的监控。

[Qw_A-Ethernet1/0/1] am user-bind mac-addr 0001-0002-0003 ip-addr 10.12.1.1

的MAC地址和IP地址绑定到Ethernet1/0/1端口。
有的交换机上绑定的配置不一样

[Qw_A] interface ethernet 1/0/2
[Qw_A-Ethernet1/0/2] user-bind ip-address 192.168.0.3 mac-address 0001-0203-0405

端口过滤配置

[Qw_A] interface ethernet1/0/1 配置端口Ethernet1/0/1的端口过滤功能。
[Qw_A-Ethernet1/0/1] ip check source ip-address mac-address
[Qw_A] dhcp-snooping 开启DHCP Snooping功能。
[Qw_A] interface ethernet1/0/2

设置与DHCP服务器相连的端口Ethernet1/0/2为信任端口。

[Qw_A-Ethernet1/0/2] dhcp-snooping trust

hernet1/0/1上启用IP过滤功能,防止客户端使用伪造的不同源IP地址对服务器进行攻击

15、BFD配置

Qw_A、Qw_B、Qw_C相互可达,在Qw_A上配置静态路由可以到达Qw_C,并使能BFD检测功能。
① 在Qw_A上配置静态路由,并使能BFD检测功能,通过BFD echo报文方式实现BFD功能。

<</SPAN>Qw_A> system-view
[Qw_A] bfd echo-source-ip 123.1.1.1
[Qw_A] interface vlan-interface 10
[Qw_A-vlan-interface10] bfd min-echo-receive-interval 300
[Qw_A-vlan-interface10] bfd detect-multiplier 7
[Qw_A-vlan-interface10] quit
[Qw_A] ip route-static 120.1.1.1 24 10.1.1.100 bfd echo-packet

② 在Qw_A上打开BFD功能调试信息开关。

<</SPAN>Qw_A> debugging bfd event
<</SPAN>Qw_A> debugging bfd scm
<</SPAN>Qw_A> terminal debugging

③ 在Qw_A上可以打开BFD功能调试信息开关,断开Hub和Qw_B之间的链路,验证配置结果。验证结果显示,
④ Qw_A能够快速感知Qw_A与Qw_B之间链路的变化。

16、QinQ配置

Provider A、Provider B之间通过Trunk端口连接,Provider A属于运营商网络的VLAN1000,Provider B属于运营商网络的VLAN2000。
Provider A和Provider B之间,运营商采用其他厂商的设备,TPID值为0x8200。
希望配置完成后达到下列要求:
Customer A的VLAN10的报文可以和Customer B的VLAN10的报文经过运营商网络的VLAN1000转发后互通;Customer A的VLAN20的报文可以
和Customer C的VLAN20的报文经过运营商网络的VLAN2000转发后互通。
[ProviderA] interface ethernet 1/0/1 # 配置端口为Hybrid端口,且允许VLAN10,VLAN20,VLAN1000和VLAN2000的报文通过,并且在发送时去掉外层Tag。

ProviderA-Ethernet1/0/1] port link-type hybrid
[ProviderA-Ethernet1/0/1] port hybrid vlan 10 20 1000 2000 untagged
[ProviderA-Ethernet1/0/1] qinq vid 1000

将来自VLAN10的报文封装VLAN ID为1000的外层Tag。

[ProviderA-Ethernet1/0/1-vid-1000] raw-vlan-id inbound 10
[ProviderA-Ethernet1/0/1-vid-1000] quit
[ProviderA-Ethernet1/0/1] qinq vid 2000

将来自VLAN20的报文封装VLAN ID为2000的外层Tag。

[ProviderA-Ethernet1/0/1-vid-2000] raw-vlan-id inbound 20
[ProviderA] interface ethernet 1/0/2 配置端口的缺省VLAN为VLAN1000。
[ProviderA-Ethernet1/0/2] port access vlan 1000
[ProviderA-Ethernet1/0/2] qinq enable

配置端口的基本QinQ功能,将来自VLAN10的报文封装VLAN ID为1000的外层Tag。

[ProviderA] interface ethernet 1/0/3

配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。

[ProviderA-Ethernet1/0/3] port link-type trunk
[ProviderA-Ethernet1/0/3] port trunk permit vlan 1000 2000
[ProviderA-Ethernet1/0/3] qinq ethernet-type 8200

为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200。

[ProviderB] interface ethernet 1/0/1

配置端口为Trunk端口,且允许VLAN1000和VLAN2000的报文通过。

[ProviderB-Ethernet1/0/1] port link-type trunk
[ProviderB-Ethernet1/0/1] port trunk permit vlan 1000 2000
[ProviderB-Ethernet1/0/1] qinq ethernet-type 8200

为与公共网络中的设备进行互通,配置端口添加外层Tag时采用的TPID值为0x8200。

[ProviderB-Ethernet1/0/1] quit
[ProviderB] interface ethernet 1/0/2 # 配置端口的缺省VLAN为VLAN2000。
[ProviderB-Ethernet1/0/2] port access vlan 2000
[ProviderB-Ethernet1/0/2] qinq enable

配置端口的基本QinQ功能,将来自VLAN20的报文封装VLAN ID为2000的外层Tag。

参考连接 :
华为交换机遇到问题总结 : https://blog.csdn.net/IO_print/article/details/100163920

Huawei交换机配置Telnet登录 : https://www.cnblogs.com/pipci/p/8075686.html
Huawei交换机VRP配置介绍 : https://www.cnblogs.com/pipci/p/8118643.html

[Huawei]华为交换机基础配置参考 : https://www.cnblogs.com/gwblogs/p/8470235.html

Huawei DHCP 全局配置与接口配置https://www.cnblogs.com/qzqdy/p/8953339.html

华为交换机配置命令总结 :https://www.cnblogs.com/hftian/p/8858343.html

转自:https://blog.csdn.net/qq_40907977/article/details/106287969?utm_medium=distribute.pc_relevant.none-task-blog-baidujs_baidulandingword-11&spm=1001.2101.3001.4242

您可能还喜欢...