华为三层交换机不同vlan互访配置方法

例如,现在有一台三层交换机需要划分3个vlan,不同的网段。vlan10 网段192.168.10.x    vlan20 网段192.168.20.x vlan30 网段 192.168.30.x。三个vlan直接能互访。

华为三层交换机不同vlan互访配置方法

方法/步骤

  1. 配置思路是不同vlan间互访需要路由器功能,由于交换机是三层交换机只需要创建vlan ,设置vlanif   Ip(此IP做为所属vlan下用户设备的网关地址)。把交换机端口划分到对应的vlan。

  2. 华为交换机创建vlan命令如下

    <Huawei>system-view

    [Huawei]vlan batch 10 20 30   批量创建 vlan 10 20 30

    华为三层交换机不同vlan互访配置方法
  3. 配置vlanif 命令如下

    [Huawei]interface Vlanif 10   进入虚拟vlan接口

    [Huawei-Vlanif10]ip address 192.168.10.1 24  设置IP地址也入输入ip address 192.168.10.1 255.255.255.0

    [Huawei-Vlanif10]qu     退出

    [Huawei]interface Vlanif 20

    [Huawei-Vlanif20]ip address 192.168.20.1 24

    [Huawei-Vlanif20]quit

    [Huawei]interface Vlanif 30

    [Huawei-Vlanif30]ip address 192.168.30.1 24

    华为三层交换机不同vlan互访配置方法
  4. 把端口划分到对应的vlan。端口1 vlan10  端口2 vlan20  端口3 vlan20

    [Huawei]interface GigabitEthernet 0/0/1   进入端口1

    [Huawei-GigabitEthernet0/0/1]port link-type access    设置端口模式为ACCESS

    [Huawei-GigabitEthernet0/0/1]port default vlan 10   设置端口1为vlan10

    [Huawei-GigabitEthernet0/0/1]qu                    退出端口配置

    [Huawei]interface GigabitEthernet 0/0/2

    [Huawei-GigabitEthernet0/0/2]port link-type access

    [Huawei-GigabitEthernet0/0/2]port default vlan 20

    [Huawei-GigabitEthernet0/0/2]qu

    [Huawei]interface GigabitEthernet 0/0/3

    [Huawei-GigabitEthernet0/0/3]port link-type access

    [Huawei-GigabitEthernet0/0/3]port default vlan 30

     

  5. 5

    配置PC的IP地址。

    PC1  IP:192.168.10.10   掩码:255.255.255.0   网关:192.168.10.1

    PC2  IP:192.168.20.20   掩码:255.255.255.0   网关:192.168.20.1

    PC3  IP:192.168.30.30   掩码:255.255.255.0   网关:192.168.30.1

     

    现在PC1与PC2 、PC3都能ping通了。

    华为三层交换机不同vlan互访配置方法
点赞