S5700的管理接口与管理IP地址

转自华为社区:https://support.huawei.com/enterprise/zh/doc/EDOC1100098004/

简介

当用户希望对设备进行管理时,需要借助管理接口和管理IP地址。本文档介绍了交换机支持的管理接口以及如何配置管理IP地址。

前提条件

本文档适用于S系列交换机所有版本的所有产品。

管理接口

常见的设备管理方式有SNMP、Web、Telnet以及通过Console口管理等。从技术的角度分析,网络管理可分为带外管理和带内管理。所谓带内管理,是指网络中的管理数据和业务数据在相同的链路中传输。当管理数据的流量较少时,对整个网络的性能影响不明显,可采用带内管理。所谓带外管理,是指网络中的管理数据与业务数据在不同的链路中传输。通过专门的网管通道实现对网络的管理可提高网络管理的效率与可靠性,也有利于提高网管数据的安全性。

用户要实现对设备的管理,首先要连接设备的管理接口。交换机当前支持的管理接口包括Console口、MiniUSB口、管理网口和业务口,下面将逐一进行介绍。用户可以根据实际需求,进行合理选择。

Console口

通过Console口登录设备适用于首次登录交换机或无法远程登录交换机,以及设备无法启动的场景。通过Console口登录设备是指使用专门的Console通信线缆将用户PC的串口与交换机的Console口相连,在进行相应的配置后实现在本地管理交换机(具体操作请参见《通过Console口首次登录设备》)。该方式是登录交换机最基本的方式,属于带外管理,也是其他登录方式(如Telnet、STelnet)的基础。PC与交换机的具体连接方式如图1所示。

图1-1 通过Console口登录交换机组网图

MiniUSB口

当用户终端PC没有可用Console口时,也可以使用MiniUSB线缆将PC的USB口连接到设备的MiniUSB口进行登录,从而实现对首次登录的设备进行基本配置和管理(具体操作请参见《通过MiniUSB口首次登录设备》)。通过MiniUSB口登录与通过Console口登录仅设备的连接方式不同,登录时的通讯参数和登录配置是一致的,也属于带外管理。当MiniUSB口和Console口同时使用时,只有MiniUSB口生效。PC与交换机的具体连接方式如图2所示。

图1-2 通过MiniUSB口登录交换机组网图

管理网口

管理网口是一种特殊的以太网接口,可以配置IP地址,但不承担业务传输。该方式属于带外管理。交换机设备面板上的ETH口为管理网口,但盒式交换机的管理网口的软件接口名称是MEth接口,框式交换机的管理网口的软件接口名称是ETH接口。PC与交换机的具体连接方式如图3所示。

图1-3 通过管理网口登录交换机组网图

业务口

业务口指的是承担业务传输的以太网接口。当通过业务口对设备进行配置管理时,网络中的管理数据和业务数据在相同的链路中传输,即采用带内管理。PC与交换机的具体连接方式如图4所示。

图1-4 通过业务口登录交换机组网图

配置管理IP地址

管理IP可在管理网口上配置,也可在业务口上配置。对于管理网口,可直接在该接口上配置IP地址。对于业务口,若设备支持二三层模式切换,在接口切换到三层模式后,可直接在三层接口上配置IP地址;否则,设备可借助VLANIF接口配置IP地址。下面将分别介绍如何在管理网口或业务口上配置管理IP地址,以及如何查看接口IP地址。

在管理网口上配置管理IP地址

  • 对于盒式交换机
    1. 执行命令interface MEth 0/0/1,进入MEth接口视图。
      <HUAWEI> system-view 
      [HUAWEI] interface MEth 0/0/1
    2. 执行命令ip address ip-address { mask | mask-length },配置MEth接口的IP地址。此处假设设备管理网口的IP地址为10.1.1.1/24
      [HUAWEI-MEth0/0/1] ip address 10.1.1.1 24
  • 对于框式交换机
    1. 执行命令interface Ethernet 0/0/0,进入ETH接口视图。
      <HUAWEI> system-view 
      [HUAWEI] interface Ethernet 0/0/0
    2. 执行命令ip address ip-address { mask | mask-length },配置ETH接口的IP地址。此处假设设备管理网口的IP地址为10.1.1.2/24
      [HUAWEI-Ethernet0/0/0] ip address 10.1.1.2 24

在业务口上配置管理IP地址

  • 通过三层接口进行配置
    1. 执行命令interface interface-type interface-number,进入以太网接口视图。此处假设设备连接PC的接口是GigabitEthernet0/0/1。
      <HUAWEI> system-view 
      [HUAWEI] interface GigabitEthernet 0/0/1
    2. 执行命令undo portswitch,配置接口切换到三层模式。缺省情况下,以太网接口工作在二层模式。
      [HUAWEI-GigabitEthernet0/0/1] undo portswitch
    3. 执行命令ip address ip-address { mask | mask-length },配置接口的IP地址。此处假设三层接口的IP地址为10.1.1.3/24
      [HUAWEI-GigabitEthernet0/0/1] ip address 10.1.1.3 24
  • 通过VLANIF接口进行配置
    1. 执行命令interface interface-type interface-number,进入以太网接口视图。此处假设设备连接PC的接口是GigabitEthernet0/0/1。
      <HUAWEI> system-view 
      [HUAWEI] interface GigabitEthernet 0/0/1
    2. 执行命令port link-type access配置接口类型为access。
      [HUAWEI-GigabitEthernet0/0/1] port link-type access
    3. 执行命令port default vlan vlan-id,配置接口的缺省VLAN并将接口加入到指定VLAN。
      [HUAWEI-GigabitEthernet0/0/1] port default vlan 4094
      [HUAWEI-GigabitEthernet0/0/1] quit
    4. 执行命令interface Vlanif vlan-id,创建VLANIF接口并进入VLANIF接口视图。
      [HUAWEI] interface Vlanif 4094
    5. 执行命令ip address ip-address { mask | mask-length },配置VLANIF接口的IP地址。此处假VLANIF接口的IP地址为10.1.1.4/24
      [HUAWEI-Vlanif4094] ip address 10.1.1.4 24

如何查看管理IP地址

  • 执行命令display ip interface [ interface-type interface-number ] ],查看接口与IP相关的信息。在接口上配置的IP地址可查看Internet Address is字段信息。

  • 执行命令display ip interface brief [ interface-type [ interface-number ] | slot slot-id [ card card-number ] ],查看接口与IP相关的摘要信息。在接口上配置的IP地址可查看IP Address/Mask字段信息。

  • 执行命令display interface [ interface-type interface-number ],查看接口信息。在接口上配置的IP地址可查看Internet Address is字段信息。

华为S系列交换机的管理接口与配置管理IP地址相关信息

点赞