华为S5700三层交换机配置DHCP

网络拓扑图如下:

需求:PC机可以从LSW1自动获取IP地址,并且所有PC网络均可互通

实施方法:

1. 在LSW 2和LSW 3上创建VLAN,并将端口加入VLAN中

LSW 2配置命令: 

复制代码
<Huawei>system-view             #进入系统视图模式
[Huawei]sysname sw2            #交换机命名为sw2
[sw2]vlan batch 100 200            #批量创建vlan 100和vlan 200
[sw2]interface Ethernet0/0/2            #进入e0/0/0/2接口视图
[sw2-Ethernet0/0/2]port link-type access            #端口设置为access
[sw2-Ethernet0/0/2]port default vlan 100            #端口加入vlan 100
[sw2-Ethernet0/0/2]quit            #退出

[sw2]interface Ethernet 0/0/3            #进入e0/0/3接口
[sw2-Ethernet0/0/3]port link-type access            #端口设置为access
[sw2-Ethernet0/0/3]port default vlan 200            #端口加入vlan 200
[sw2-Ethernet0/0/3]quit            #退出

[sw2]interface Ethernet 0/0/1            #进入e0/0/1接口
[sw2-Ethernet0/0/1]port link-type trunk            #端口设置为trunk
[sw2-Ethernet0/0/1]port trunk allow-pass vlan all            #允许所有vlan数据通行
[sw2-Ethernet0/0/1]quit            #退出
复制代码

 检查LSW 2配置:

[sw2]display vlan            #查看vlan信息

 

LSW 3配置命令:

复制代码
<Huawei>system-view             #进入系统视图
[Huawei]sysname sw3            #交换机命名为sw3
[sw3]vlan batch 100 200            #批量创建vlan 100和vlan 200
[sw3]interface Ethernet 0/0/2            #进入e0/0/2接口
[sw3-Ethernet0/0/2]port link-type  access            #端口设置为access
[sw3-Ethernet0/0/2]port default vlan 100            #端口划分至vlan 100
[sw3-Ethernet0/0/2]quit             #退出

[sw3]interface Ethernet 0/0/3            #进入e0/0/3接口
[sw3-Ethernet0/0/3]port link-type access            #端口设置为access
[sw3-Ethernet0/0/3]port default vlan 200        #端口划分至vlan 200
[sw3-Ethernet0/0/3]quit            #退出

[sw3]interface Ethernet 0/0/1            #进入e0/0/1接口
[sw3-Ethernet0/0/1]port link-type trunk             #端口设置为trunk
[sw3-Ethernet0/0/1]port trunk allow-pass vlan all             #允许所有vlan数据通行
[sw3-Ethernet0/0/1]quit            #退出
复制代码

检查LSW 3配置

[sw3]display vlan            #查看vlan信息

 

LSW 1配置命令:

复制代码
<Huawei>system-view             #进入系统视图
[Huawei]sysname sw1            #交换机命名为sw1
[sw1]vlan batch 100 200            #批量创建vlan 100和vlan 200
[sw1]interface GigabitEthernet 0/0/1            #进入g0/0/1接口
[sw1-GigabitEthernet0/0/1]port link-type trunk        #设置为trunk
[sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan 100 200        #只允许vlan 100和vlan 200通过
[sw1-GigabitEthernet0/0/1]quit            #退出

[sw1]interface GigabitEthernet 0/0/2            #进入g0/0/2接口
[sw1-GigabitEthernet0/0/2]port link-type trunk            #设置为trunk
[sw1-GigabitEthernet0/0/2]port trunk allow-pass vlan 100 200            #只允许vlan 100和vlan 200通过
[sw1-GigabitEthernet0/0/2]quit            #退出

[sw1]dhcp enable            #开启dhcp功能
[sw1]interface Vlanif 100            #进入vlan 100
[sw1-Vlanif100]ip address 192.168.100.1 255.255.255.0        #设置接口地址为192.168.100.1/24
[sw1-Vlanif100]dhcp select global            #在vlan 100中设置dhcp为全局模式
[sw1-Vlanif100]quit            #退出

[sw1]ip pool vlan100            #创建dhcp地址池为vlan100
[sw1-ip-pool-vlan100]network 192.168.100.0 mask 255.255.255.0            #配置网段
[sw1-ip-pool-vlan100]gateway-list 192.168.100.1            #配置网关地址为192.168.100.1
[sw1-ip-pool-vlan100]dns-list 1.1.1.1            #配置dns地址为1.1.1.1
[sw1-ip-pool-vlan100]lease day 5            #配置租期为5天
[sw1-ip-pool-vlan100]excluded-ip-address 192.168.100.100 192.168.100.254            #去除不想分配的IP,从192.168.100.100~192.168.100.254
[sw1-ip-pool-vlan100]quit            #退出

[sw1]interface vlanif 200            #进入vlan 200
[sw1-Vlanif200]ip address 192.168.200.1 255.255.255.0        #设置接口地址为192.168.200/24
[sw1-Vlanif200]dhcp select global             #在vlan 200中设置dhcp为全局模式
[sw1-Vlanif200]quit            #退出
[sw1]ip pool vlan200            #创建地址池为vlan200
[sw1-ip-pool-vlan200]network 192.168.200.0 mask 255.255.255.0            #配置网段
[sw1-ip-pool-vlan200]gateway-list 192.168.200.1            #配置网关地址为192.168.200.1
[sw1-ip-pool-vlan200]dns-list 2.2.2.2            #配置dns地址
[sw1-ip-pool-vlan200]lease day 7            #租期为7天
[sw1-ip-pool-vlan200]excluded-ip-address 192.168.200.250 192.168.200.254            #去除不想分配的IP,从192.168.200.250~192.168.200.254
[sw1-ip-pool-vlan200]quit             #退出
复制代码

检查LSW 1配置:

[sw1]display vlan            #查看vlan信息

 

[sw1]display current-configuration            #检查所有配置

 

2. 将所有PC设置为DHCP,分别查看IP地址与网络连通状态

PC 1【IP地址为192.168.100.99,ping PC 4网络可以抵达【192.168.200.248】】:

 

PC 2【IP地址为192.168.200.249,ping PC 3网络可以抵达【192.168.100.98】】:

 

PC 3【IP地址为192.168.100.98,ping PC 2网络可以抵达【192.168.200.249】】:

 

PC 4【IP地址为192.168.200.248,ping PC 1网络可以抵达【192.168.100.99】】:

转自:https://www.cnblogs.com/xiykj/p/14263701.html

您可能还喜欢...