Huawei DHCP 全局配置与接口配置

说明:
1.交换机Ge0/0/1口和Ge0/0/2口配置基于全局的DHCP;
2.交换机Ge0/0/3口配置基于端口的DHCP;
3.交换机上配置vlan 10 、vlan 20 、vlan 30。vlan 10 地址192.168.10.1,vlan 20地址192.168.20.1,vlan 30地址192.168.30.1。
4.Ge0/0/1属于vlan 10,Ge0/0/2属于vlan 20,Ge0/0/3属于vlan 30。
配置:
[Huawei]dis cu
#
sysname Huawei
#
vlan batch 10 20 30 “创建VLAN”
#
cluster enable
ntdp enable
ndp enable
#
drop illegal-mac alarm
#
[Quidway] dhcp enable // 在配置模式下“启用DHCP服务”
#
diffserv domain default
#
drop-profile default
#
[Quidway-ip-pool-vlan10-pool] ip pool vlan10-pool // 在IP-POOL 模式下“基于全局配置的DHCP地址池”
[Quidway-ip-pool-vlan10-pool] domain-name h3c.com
[Quidway-ip-pool-vlan10-pool] gateway-list 192.168.10.1
[Quidway-ip-pool-vlan10-pool] network 192.168.10.0 mask 255.255.255.0
[Quidway-ip-pool-vlan10-pool] dns-list 3.3.3.2
[Quidway-ip-pool-vlan10-pool] excluded-ip-address 192.168.10.2 //排除IP 10.2 不分配
[Quidway-ip-pool-vlan10-pool] excluded-ip-address 192.168.10.200 192.168.10.254 //排除200-254 不分配
[Quidway-ip-pool-vlan10-pool] static-bind ip-address 192.168.10.9 mac-address 28d2-4469-5a55 // 绑定 IP 192.168.10.9 固定分配给MAC 为28d2-4469-5a55的机器,需池中IP
//当一个用户需要固定的IP地址时,可以将地址池中没有在使用的IP地址与用户的MAC地址绑定。
[Quidway-ip-pool-vlan10-pool] lease day 10 //租期10天
[Quidway-ip-pool-vlan10-pool] quit
#
ip pool vlan20-pool “基于全局配置的DHCP地址池”
gateway-list 192.168.20.1
network 192.168.20.0 mask 255.255.255.0
dns-list 202.101.172.35
#

interface Vlanif30
ip address 192.168.30.1 255.255.255.0
dhcp select interface // “设置DHCP基于端口配置”
dhcp server excluded-ip-address 192.168.30.201 192.168.30.254 //“排查192.168.20.201到192.168.30.254这些地址”
dhcp server dns-list 8.8.8.8
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 10
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 20
#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 30
#

#
interface NULL0
#
user-interface con 0
user-interface vty 0 4
#
return
[Huawei]

(说明:上面红色字体部分是基于全局配置的,基于全局配置情况要在全局模式下设置dhcp服务的地址池、dns、网关等;绿色字体部分是基于端口配置的,基于端口配置的部分要在int vlan 30的接口下进行配置dhcp的dns、网关、地址池等。)

查看交换机上的arp表:

[Huawei]dis arp

IP ADDRESS MAC ADDRESS EXPIRE(M) TYPE INTERFACE VPN-INSTANCE

VLAN

——————————————————————————

192.168.10.1 4c1f-ccb7-23ea I – Vlanif10

192.168.10.254 5489-98cf-bd73 1 D-0 GE0/0/110

192.168.10.253 5489-98cf-2650 1 D-0 GE0/0/110

192.168.10.252 5489-98cf-bd73 1 D-0 GE0/0/110

192.168.10.251 5489-98cf-2650 1 D-0 GE0/0/110

192.168.20.1 4c1f-ccb7-23ea I – Vlanif20

192.168.20.254 5489-98cf-8b50 1 D-0 GE0/0/220

192.168.20.253 5489-98cf-5c20 1 D-0 GE0/0/220

192.168.20.252 5489-98cf-8b50 1 D-0 GE0/0/220

192.168.20.251 5489-98cf-5c20 1 D-0 GE0/0/220

192.168.30.1 4c1f-ccb7-23ea I – Vlanif30

192.168.30.200 5489-98cf-b623 1 D-0 GE0/0/330

192.168.30.199 5489-98cf-1103 1 D-0 GE0/0/330

——————————————————————————

Total:13 Dynamic:10 Static:0 Interface:3

[Huawei]

DHCP维护
在确认需要清除DHCP服务器的统计信息后,请在用户视图下执行
reset dhcp server statistics命令。
在确认需要清除DHCP中继的统计信息后,请在用户视图下执行
reset dhcp relay statistics命令。
使用命令display dhcp server statistics查看DHCP服务器的统计信息。
使用命令display ip pool name ip-pool-name [ low-ip-address high-ip-address | all | expired | conflict | used ]查看已经配置的全局地址池信息。
使用display dhcp relay { all | interface interface-type interface-number }命令查看VLANIF接口配置的中继DHCP服务器组和服务器组对应的服务器。
使用display dhcp relay statistics命令查看DHCP Relay统计信息。
使用display dhcp server group [ group-name ]命令查看DHCP服务器组成员的配置信息。
释放
Dis ip pool 查看设备的地址池
reset ip pool interface xx all //释放针对基于接口的地址池
reset ip pool name yy all //释放针对全局的地址池
执行命
令dhcp relay release client-ip-address mac-address [ server-ip-address | vpn-instance vpn-instance-name ],向DHCP服务器申请释放DHCP客户端已经获取到的IP地址。

您可能还喜欢...